PHP

Joomla 4 requires PHP 7 or higher to run. In case you are running lower version of PHP, you will get message before installation:

Your host needs to use PHP 7.0 or higher to run this version of Joomla!

Joomla! 3's had minimum PHP version requirement of 5.3.10.