Forum


Filip
28%
Posts: 29

TF Mail pro gives error when try to edit mail

TF Mail
January 02, 2024

When I try to edit a newsletter I get an error:

1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '= WHERE `a`.`mail_id` = '2' ORDER BY a.send_date DESC' at line 3 

The (automated) newsletter still works but I can't edit it.

What is wrong?

Joomla 4.4.1 - TF Mail 3.1.0 - Tech Fry lib 2.6.8


Tech Fry
100%
Posts: 778

January 03, 2024

Please update the component to the latest version (3.1.8) and check again if the error is coming.

Thank you


Filip
28%
Posts: 29

January 03, 2024

I did a manual update to 3.1.8 what took a long time to execute.

After that I received a warning that the language files where not updated.

As a result I did have all COM_TF_MAIL_xxx mentions in place everywhere in the admin panels. But the component seems to work again (I didn't had the SQL warning when I try to edit a newsletter).

But the component takes a long time to open, even for just showing the dashboard and so. It takes over 10 seconds to show the dashboard where normally (and other components) it opens under 1 second.

I also lost the download key, I had to reenter it...

And, as a test if it could fix the language files, I did also install once the free version of TF mail over the pro version but it had the same problem, so I reinstalled the pro version. As far as I see I don't see a seperate install but I received 2 warnings about the missing download key.

I tried to append a screenshot but then I get an error too.

 


Filip
28%
Posts: 29

January 03, 2024

Whe I try to send a file (screenshot) here I get an error:

TF_ERROR_INVALID_SAVE_FOLDER

 

 


Filip
28%
Posts: 29

January 03, 2024

When I'm in the update screen in Joomla admin I get a bunch of warnings :

Could not open update site....

All about the Tech Fry extentions. Is that normal? It happens a lot, not only now but also in the past.


Tech Fry
100%
Posts: 778

January 03, 2024

It seems that the update server is not correct. Please navigate to:

System > Update > Update Sites

Then, search for TF Mail. The correct update server for the component is "https://updates.techfry.com/components/tfmail.xml". You can delete the others.

For language files, Try "Install Languages" from the dashboard.

Finally, please enable debug mode from the Global configuration and then open the component dashboard. It will show which query is taking time to load.

Thank you!

 


Filip
28%
Posts: 29

January 03, 2024

I did try the 'Install languages' but all I get (after a long time) is the same error as with the install that the languages could not be updated.

I restored the language files manually, both language folders under component/TFMail and administrator/component/TFMail where gone, I copied them from a local copy of the site (old version of TFMail) so most terms are OK but not all.

I also enabled the debug mode but for the dashboard itself it gives no extra info, when I choose an option in the dashbourd I see also the query but thos loads fine, it is the dashboard itself that takes ages. I wonder if it has to do with the language problem.


Login to Reply